Activation and Cancellations Stalled
Incident Report for Relay
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 22:21 EDT
Investigating
We are currently investigating this issue.
Posted Sep 25, 2020 - 19:07 EDT
This incident affected: Relay Product Functionality and Activation | Provisioning.