Enterprise Support Ticketing Currently Down
Incident Report for Relay
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 12:14 EDT
Identified
Our inbound ticketing system for Enterprise support is currently down and is unable to process new inbound tickets or replies from our Enterprise customers. We are working with our platform provider to get our ticketing system back up and running as soon as possible. If you have any pressing matters that need to be addressed immediately, please contact your Customer Success Manager or Trial contact directly for a more timely response until our ticketing platform is back up and running. We appreciate your patience.
Posted Mar 23, 2021 - 10:46 EDT
This incident affected: Help Center.