Relay Dashboard Access Error
Incident Report for Relay
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 11:26 EST
Investigating
We are currently investigating an issue regarding customers experiencing an Internal Error when attempting to access the Relay Dash portal. We are actively working on the issue and will update here once we have identified the root cause.
Posted Jan 07, 2021 - 11:25 EST
This incident affected: Relay Product Functionality and Account Portal.